Schritt-für-Schritt-Anleitung Kanabis: Unterschied zwischen den Versionen

Aus Dokumentation
Wechseln zu:Navigation, Suche
(Automatisierte Rechtschreib-/Formatierungskorrektur)
 
(15 dazwischenliegende Versionen von 4 Benutzern werden nicht angezeigt)
Zeile 1: Zeile 1:
 +
{{UnderConstruction}}
 +
<div style="text-align:justify;">
 
=Projekt anlegen=
 
=Projekt anlegen=
 
Menü: Datei => Neu
 
Menü: Datei => Neu
 
Neu: Ein neues Projekt wird erstellt. Diese Funktion entspricht dem Button  auf Ihrer Menüleiste. KANABIS legt ein neues Projekt für Sie an. Dazu müssen Sie in der folgenden Projektmaske einige Eingaben machen:
 
Neu: Ein neues Projekt wird erstellt. Diese Funktion entspricht dem Button  auf Ihrer Menüleiste. KANABIS legt ein neues Projekt für Sie an. Dazu müssen Sie in der folgenden Projektmaske einige Eingaben machen:
<div class=„res-img“>[[File:kanabis_001.png|800px|center]]</div><br />  
+
<div class="res-img">[[File:kanabis_001.png|800px|center]]</div><br />  
  
 
==Bezugshorizont==
 
==Bezugshorizont==
Nachdem die Eingaben bestätigt wurden öffnet sich ein weiterer Dialog für den Bezugshorizont.
+
Nachdem die Eingaben bestätigt wurden, öffnet sich ein weiterer Dialog für den Bezugshorizont.
  
<div class=„res-img“>[[File:kanabis_002.png|400px|center]]</div><br />  
+
<div class="res-img">[[File:kanabis_002.png|400px|center]]</div><br />  
  
Für die Höhenlage des Projektes werden hier die Rahmendaten eingegeben. Es genügen runde 10er –Werte bei der Höhe, die maximale Abweichung nach oben und unten kann den örtlichen Gegebenheiten angepasst werden. Durch die Eingaben entsteht ein Höhenkorridor , innerhalb dessen Höheneingaben angenommen werden. Alles was außerhalb liegt, wird abgewiesen.
+
Für die Höhenlage des Projektes werden hier die Rahmendaten eingegeben. Es genügen runde 10er –Werte bei der Höhe, die maximale Abweichung nach oben und unten kann den örtlichen Gegebenheiten angepasst werden. Durch die Eingaben entsteht ein Höhenkorridor, innerhalb dessen Höheneingaben angenommen werden. Alles, was außerhalb liegt, wird abgewiesen.
  
 
==Bearbeitungsfenster==
 
==Bearbeitungsfenster==
 
Nachdem Sie alle grundlegenden Einstellungen vorgenommen haben, öffnet sich das leere Bearbeitungsfenster. Dieses können Sie natürlich über die üblichen Windows Buttons auch in den Vollbildmodus schalten.
 
Nachdem Sie alle grundlegenden Einstellungen vorgenommen haben, öffnet sich das leere Bearbeitungsfenster. Dieses können Sie natürlich über die üblichen Windows Buttons auch in den Vollbildmodus schalten.
<div class=„res-img“>[[File:kanabis_003.png|800px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_003.png|800px|center]]</div><br />
  
 
=Projektaufbau=
 
=Projektaufbau=
Zeile 19: Zeile 21:
 
==Hintergrundgrafiken importieren==
 
==Hintergrundgrafiken importieren==
 
Für eine einfache Orientierung im Projektgebiet können Sie sich verschiedene Hintergrundgrafiken ins Projekt laden.
 
Für eine einfache Orientierung im Projektgebiet können Sie sich verschiedene Hintergrundgrafiken ins Projekt laden.
<div class=„res-img“>[[File:kanabis_009.png|400px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_009.png|400px|center]]</div><br />
 
===DXF Import als Hintergrundbild===
 
===DXF Import als Hintergrundbild===
Das Drawing Interchange File Format (DXF) ist ein von Autodesk spezifiziertes Dateiformat zum CAD-Datenaustausch. Dies ermöglicht Ihnen in Kanabis CAD Dateien im Hintergrund anzeigen zu lassen.
+
Das Drawing Interchange File Format (DXF) ist ein von Autodesk spezifiziertes Dateiformat zum CAD-Datenaustausch. Dies ermöglicht Ihnen, in Kanabis CAD-Dateien im Hintergrund anzeigen zu lassen.
 +
Das eingelesene DXF-Bild wird über den Windows-Pfad gesucht und im Netzbild dargestellt. Es können beliebig viele DXF-Bilder eingelesen und dargestellt werden. Kanabis bietet die Möglichkeit, einzelne DXF-Bilder am Bildschirm einzugrauen, um den Kontrast zum Kanalnetzbild hervorzuheben.  
  
 
Menü: Ansicht => Hintergrundbilder
 
Menü: Ansicht => Hintergrundbilder
  
<div class=„res-img“>[[File:kanabis_010.png|800px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_010.png|800px|center]]</div><br />
  
Wenn Sie vom Auftraggeber einen DXF-Plan können Sie diesen in Kanabis hinterlegen. Sie wählen unter Ansicht => Hintergrundbilder den Pfad der DXF-Datei aus und die digitale Zeichnung wird im Netzbildfenster dargestellt.
+
Wenn Sie vom Auftraggeber einen DXF-Plan erhalten, können Sie diesen in Kanabis hinterlegen. Sie wählen unter Ansicht => Hintergrundbilder den Pfad der DXF-Datei aus und die digitale Zeichnung wird im Netzbildfenster dargestellt.
  
<div class=„res-img“>[[File:kanabis_008.png|600px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_008.png|600px|center]]</div><br />
 +
 
 +
 
 +
{{Hinweis-Box
 +
|Text = <br> Mit dem Menüpunkt Ansicht => Konstruktionspunkte aktivieren können DXF-Punkte für Konstruktionszwecke aktiviert werden. Dabei werden DXF-Punkte nur im sichtbaren Zoomfenster aktiviert, alle Punkte außerhalb bleiben passiv. Durch Konstruktionspunkte deaktivieren kann die Aktion rückgängig gemacht werden.}}
  
 
===WMS Grafiken===
 
===WMS Grafiken===
Im Rahmen der Spezifikationen des Open Geospatial Consortium (OGC) kann ein WMS - Karten aus Rasterdaten und Vektordaten visualisieren. Im Sinne eines verteilten GIS besitzt ein WMS nur die Fähigkeit zur Visualisierung dieser und für eine allgemeine Abfrage der zugrundeliegenden Sachdaten. Das Ergebnis, also die Karte, wird vom WMS in der Regel im einfachen Grafikformat zurückgegeben. Daher kann der Nutzer einen Web Map Service grundlegend über seinen Webbrowser ansprechen, in dem die Karte dann angezeigt werden kann. Somit ist der Web Map Service Bestandteil eines Web GIS. (GISWIKI.org) Einer der bekanntesten WMS Dienste dürfte die OpenStreetMap sein. Hier können Sie vorgefertigte topologische Karten in Kanabis hinterlegen. Link: https://www.terrestris.de/en/openstreetmap-wms/
+
Im Rahmen der Spezifikationen des Open Geospatial Consortium (OGC) kann ein WMS Karten aus Rasterdaten und Vektordaten visualisieren. Im Sinne eines verteilten GIS besitzt ein WMS nur die Fähigkeit zur Visualisierung dieser und für eine allgemeine Abfrage der zugrundeliegenden Sachdaten. Das Ergebnis, also die Karte, wird vom WMS in der Regel im einfachen Grafikformat zurückgegeben. Daher kann der Nutzer einen Web Map Service grundlegend über seinen Webbrowser ansprechen, in dem die Karte dann angezeigt werden kann. Somit ist der Web Map Service Bestandteil eines Web GIS. (GISWIKI.org) Einer der bekanntesten WMS Dienste dürfte die OpenStreetMap sein. Hier können Sie vorgefertigte topologische Karten in Kanabis hinterlegen. Link: https://www.terrestris.de/en/openstreetmap-wms/
  
Auch bieten die meisten Landesvermessungsdienste verschieden WMS Dienste wie Orthophotos kostenpflichtig oder kostenlos an.  
+
Auch bieten die meisten Landesvermessungsdienste verschiedene WMS Dienste wie Orthophotos kostenpflichtig oder kostenlos an.  
  
<div class=„res-img“>[[File:kanabis_012.png|600px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_012.png|600px|center]]</div><br />
  
 
Nachdem die richtigen Einstellungen getroffen wurden, wird die WMS Grafik im Netzbildfenster dargestellt.
 
Nachdem die richtigen Einstellungen getroffen wurden, wird die WMS Grafik im Netzbildfenster dargestellt.
  
<div class=„res-img“>[[File:kanabis_011.png|600px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_011.png|600px|center]]</div><br />
 
 
Hinweis:
 
Die Reihenfolge im Menü der Hintergrundgrafiken gibt an, welche Grafik oben zuerst angezeigt wird.
 
Sie können die angezeigte Reihenfolge der Rastergrafiken über die Buttons "nach oben" und "nach unten" steuern:
 
 
 
<div class=„res-img“>[[File:kanabis_013.png|600px|center]]</div><br />
 
  
 +
{{Hinweis-Box
 +
|Text = <br>Die Reihenfolge im Menü der Hintergrundgrafiken gibt an, welche Grafik oben zuerst angezeigt wird.
 +
Sie können die angezeigte Reihenfolge der Rastergrafiken über die Buttons "nach oben" und "nach unten" steuern: <div class="res-img">[[File:kanabis_013.png|600px|center]]</div><br />
 +
}}
  
 
==Daten einlesen==
 
==Daten einlesen==
Zeile 54: Zeile 59:
 
Unter Projekt => Aufbauen werden folgende Menüpunkte angeboten:  
 
Unter Projekt => Aufbauen werden folgende Menüpunkte angeboten:  
  
<div class=„res-img“>[[File:kanabis_004.png|400px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_004.png|400px|center]]</div><br />
  
 
Eine detaillierte Beschreibung und Anwendung der Schnittstellen finden Sie unter  [[Kanabis Schnittstellen]].
 
Eine detaillierte Beschreibung und Anwendung der Schnittstellen finden Sie unter  [[Kanabis Schnittstellen]].
Zeile 60: Zeile 65:
 
*CARD1: hier übernehmen wir die Koordinaten des Tiefbauplanungssystems CARD1 im Format der Version 7.0 als ASCII (=Punkte)- und POL (=Linien)-Datei.
 
*CARD1: hier übernehmen wir die Koordinaten des Tiefbauplanungssystems CARD1 im Format der Version 7.0 als ASCII (=Punkte)- und POL (=Linien)-Datei.
 
*Freies Format: erlaubt das Einlesen von beliebig formatierten Koordinaten. Einzige Voraussetzung: die Koordinaten müssen in Spalten angeordnet sein.
 
*Freies Format: erlaubt das Einlesen von beliebig formatierten Koordinaten. Einzige Voraussetzung: die Koordinaten müssen in Spalten angeordnet sein.
*Spalten Format: Hier können Sie über ein vorangelegtes Spaltenformat, einfach Daten über das Spaltenformat importieren (CSV): Homogen (Spaltengröße ist einheitlich) und Heterogen (Spaltengröße ist nicht einheitlich)
+
*Spalten Format: Hier können Sie über ein vorangelegtes Spaltenformat einfach Daten über das Spaltenformat importieren (CSV): Homogen (Spaltengröße ist einheitlich) und Heterogen (Spaltengröße ist nicht einheitlich)
 
*Zwischenablage: Kopieren Sie Daten über die Zwischenablage einfach in das Modell. Das Format ist ein Spaltenformat.
 
*Zwischenablage: Kopieren Sie Daten über die Zwischenablage einfach in das Modell. Das Format ist ein Spaltenformat.
 
*ISYBAU K, LK: dies ist ein herstellerunabhängiges ASCII-Format zum Transport von lagebezogenen Kanaldaten und liefert komplette, dreidimensionale Kanalnetze mit Deckel- und Sohlhöhen, Rohrdimension und -material.  
 
*ISYBAU K, LK: dies ist ein herstellerunabhängiges ASCII-Format zum Transport von lagebezogenen Kanaldaten und liefert komplette, dreidimensionale Kanalnetze mit Deckel- und Sohlhöhen, Rohrdimension und -material.  
 
*ISYBAU XML: Nach dem aktuellen Standard werden die Kanalnetze per ISYBAU XML Schnittstelle übertragen.
 
*ISYBAU XML: Nach dem aktuellen Standard werden die Kanalnetze per ISYBAU XML Schnittstelle übertragen.
 
  
 
==Konstruktion von Schächten und Haltungen==
 
==Konstruktion von Schächten und Haltungen==
Neben der schnellen und rationellen Übernahme von fertigen Kanalnetzen aus Datenfiles und der schachtweisen Digitalisierung von DXF-Bildern kann der Bearbeiter jederzeit per Hand weitere Schächte und Haltungen eingeben oder vorhandene Schächte in ihrer Lage konstruktiv verändern. Dazu werden die folgenden Möglichkeiten angeboten.
+
Neben der schnellen und rationellen Übernahme von fertigen Kanalnetzen aus Datenfiles und der schachtweisen Digitalisierung von DXF-Bildern kann der Bearbeiter jederzeit per Hand weitere Schächte und Haltungen eingeben oder vorhandene Schächte in ihrer Lage konstruktiv verändern. Dazu werden die folgenden Möglichkeiten angeboten:
 
 
 
 
  
 
*Absolut
 
*Absolut
 
*Polar
 
*Polar
*Othogonal
+
*Orthogonal
 
*Kreis-Kreis
 
*Kreis-Kreis
 
*Schacht & Haltung
 
*Schacht & Haltung
  
Einzelne Informationionen [[Kanabis - Konstruktion von Schächten]].
+
Einzelne Informationen zu den unterschiedlichen Konstruktionsmöglichkeiten finden Sie unter [[Kanabis Haltungen]].
  
 
'''Beispiel DXF Abzeichnen'''
 
'''Beispiel DXF Abzeichnen'''
  
Sie die Möglichkeit mittels Schacht/Neu/absolut in die vorhandenen Schachtsymbole der DXF-Zeichnung neue Kanabis-Schächte zu setzen. Die Lagekoordinaten werden dabei automatisch erzeugt, Deckel- und Sohlhöhen müssen Sie aus den Plantexten entnehmen und in die Schachtmaske eintragen.  
+
Sie haben die Möglichkeit, mittels Schacht/Neu/absolut in die vorhandenen Schachtsymbole der DXF-Zeichnung neue Kanabis-Schächte zu setzen. Die Lagekoordinaten werden dabei automatisch erzeugt, Deckel- und Sohlhöhen müssen Sie aus den Plantexten entnehmen und in die Schachtmaske eintragen.  
Wenn alle Schächte abdigitalisiert sind, verbinden Sie sie mit Haltung. So können Sie schnell und einfach nachdigitalisieren und das komplette Netzbild abbilden.  
+
Wenn alle Schächte abdigitalisiert sind, verbinden Sie sie mit Haltungen. So können Sie schnell und einfach nachdigitalisieren und das komplette Netzbild abbilden.
 +
 
 +
Mit dem Menüpunkt Ansicht => Konstruktionspunkte aktivieren können DXF-Punkte für Konstruktionszwecke aktiviert werden. Dabei werden DXF-Punkte nur im sichtbaren Zoomfenster aktiviert, alle Punkte außerhalb bleiben passiv. Durch Konstruktionspunkte deaktivieren kann die Aktion rückgängig gemacht werden.
  
 
Im Hintergrund liegt die DXF-Datei mit den geplanten Mischwasserkanälen (Magenta), diese wurden in diesem Fall nachdigitalisiert.
 
Im Hintergrund liegt die DXF-Datei mit den geplanten Mischwasserkanälen (Magenta), diese wurden in diesem Fall nachdigitalisiert.
<div class=„res-img“>[[File:kanabis_021.png|800px|center]]</div><br />
+
<div class="res-img">[[File:kanabis_021.png|800px|center]]</div><br />

Aktuelle Version vom 31. August 2026, 10:49 Uhr

SEITE WIRD BEARBEITET!

Diese Seite wird noch bearbeitet - daher können die Darstellungen und Erklärungen noch unvollständig sein!
Der Aufbau dieser Seite ist noch in Bearbeitung!

Projekt anlegen

Menü: Datei => Neu Neu: Ein neues Projekt wird erstellt. Diese Funktion entspricht dem Button auf Ihrer Menüleiste. KANABIS legt ein neues Projekt für Sie an. Dazu müssen Sie in der folgenden Projektmaske einige Eingaben machen:

Kanabis 001.png

Bezugshorizont

Nachdem die Eingaben bestätigt wurden, öffnet sich ein weiterer Dialog für den Bezugshorizont.

Kanabis 002.png

Für die Höhenlage des Projektes werden hier die Rahmendaten eingegeben. Es genügen runde 10er –Werte bei der Höhe, die maximale Abweichung nach oben und unten kann den örtlichen Gegebenheiten angepasst werden. Durch die Eingaben entsteht ein Höhenkorridor, innerhalb dessen Höheneingaben angenommen werden. Alles, was außerhalb liegt, wird abgewiesen.

Bearbeitungsfenster

Nachdem Sie alle grundlegenden Einstellungen vorgenommen haben, öffnet sich das leere Bearbeitungsfenster. Dieses können Sie natürlich über die üblichen Windows Buttons auch in den Vollbildmodus schalten.

Kanabis 003.png

Projektaufbau

Hintergrundgrafiken importieren

Für eine einfache Orientierung im Projektgebiet können Sie sich verschiedene Hintergrundgrafiken ins Projekt laden.

Kanabis 009.png

DXF Import als Hintergrundbild

Das Drawing Interchange File Format (DXF) ist ein von Autodesk spezifiziertes Dateiformat zum CAD-Datenaustausch. Dies ermöglicht Ihnen, in Kanabis CAD-Dateien im Hintergrund anzeigen zu lassen. Das eingelesene DXF-Bild wird über den Windows-Pfad gesucht und im Netzbild dargestellt. Es können beliebig viele DXF-Bilder eingelesen und dargestellt werden. Kanabis bietet die Möglichkeit, einzelne DXF-Bilder am Bildschirm einzugrauen, um den Kontrast zum Kanalnetzbild hervorzuheben.

Menü: Ansicht => Hintergrundbilder

Kanabis 010.png

Wenn Sie vom Auftraggeber einen DXF-Plan erhalten, können Sie diesen in Kanabis hinterlegen. Sie wählen unter Ansicht => Hintergrundbilder den Pfad der DXF-Datei aus und die digitale Zeichnung wird im Netzbildfenster dargestellt.

Kanabis 008.png


WMS Grafiken

Im Rahmen der Spezifikationen des Open Geospatial Consortium (OGC) kann ein WMS Karten aus Rasterdaten und Vektordaten visualisieren. Im Sinne eines verteilten GIS besitzt ein WMS nur die Fähigkeit zur Visualisierung dieser und für eine allgemeine Abfrage der zugrundeliegenden Sachdaten. Das Ergebnis, also die Karte, wird vom WMS in der Regel im einfachen Grafikformat zurückgegeben. Daher kann der Nutzer einen Web Map Service grundlegend über seinen Webbrowser ansprechen, in dem die Karte dann angezeigt werden kann. Somit ist der Web Map Service Bestandteil eines Web GIS. (GISWIKI.org) Einer der bekanntesten WMS Dienste dürfte die OpenStreetMap sein. Hier können Sie vorgefertigte topologische Karten in Kanabis hinterlegen. Link: https://www.terrestris.de/en/openstreetmap-wms/

Auch bieten die meisten Landesvermessungsdienste verschiedene WMS Dienste wie Orthophotos kostenpflichtig oder kostenlos an.

Kanabis 012.png

Nachdem die richtigen Einstellungen getroffen wurden, wird die WMS Grafik im Netzbildfenster dargestellt.

Kanabis 011.png

Daten einlesen

Neben der schacht- und haltungsweisen Konstruktion von Kanalnetzen bietet Kanabis die Möglichkeit, komplette Netze aus vorhandenen Dateiformaten einzulesen. Unter Projekt => Aufbauen werden folgende Menüpunkte angeboten:

Kanabis 004.png

Eine detaillierte Beschreibung und Anwendung der Schnittstellen finden Sie unter Kanabis Schnittstellen.

  • Kanal++ : direkte Übernahme der Netzdaten aus dem Hydraulikpaket von ++SYSTEMS
  • CARD1: hier übernehmen wir die Koordinaten des Tiefbauplanungssystems CARD1 im Format der Version 7.0 als ASCII (=Punkte)- und POL (=Linien)-Datei.
  • Freies Format: erlaubt das Einlesen von beliebig formatierten Koordinaten. Einzige Voraussetzung: die Koordinaten müssen in Spalten angeordnet sein.
  • Spalten Format: Hier können Sie über ein vorangelegtes Spaltenformat einfach Daten über das Spaltenformat importieren (CSV): Homogen (Spaltengröße ist einheitlich) und Heterogen (Spaltengröße ist nicht einheitlich)
  • Zwischenablage: Kopieren Sie Daten über die Zwischenablage einfach in das Modell. Das Format ist ein Spaltenformat.
  • ISYBAU K, LK: dies ist ein herstellerunabhängiges ASCII-Format zum Transport von lagebezogenen Kanaldaten und liefert komplette, dreidimensionale Kanalnetze mit Deckel- und Sohlhöhen, Rohrdimension und -material.
  • ISYBAU XML: Nach dem aktuellen Standard werden die Kanalnetze per ISYBAU XML Schnittstelle übertragen.

Konstruktion von Schächten und Haltungen

Neben der schnellen und rationellen Übernahme von fertigen Kanalnetzen aus Datenfiles und der schachtweisen Digitalisierung von DXF-Bildern kann der Bearbeiter jederzeit per Hand weitere Schächte und Haltungen eingeben oder vorhandene Schächte in ihrer Lage konstruktiv verändern. Dazu werden die folgenden Möglichkeiten angeboten:

  • Absolut
  • Polar
  • Orthogonal
  • Kreis-Kreis
  • Schacht & Haltung

Einzelne Informationen zu den unterschiedlichen Konstruktionsmöglichkeiten finden Sie unter Kanabis Haltungen.

Beispiel DXF Abzeichnen

Sie haben die Möglichkeit, mittels Schacht/Neu/absolut in die vorhandenen Schachtsymbole der DXF-Zeichnung neue Kanabis-Schächte zu setzen. Die Lagekoordinaten werden dabei automatisch erzeugt, Deckel- und Sohlhöhen müssen Sie aus den Plantexten entnehmen und in die Schachtmaske eintragen. Wenn alle Schächte abdigitalisiert sind, verbinden Sie sie mit Haltungen. So können Sie schnell und einfach nachdigitalisieren und das komplette Netzbild abbilden.

Mit dem Menüpunkt Ansicht => Konstruktionspunkte aktivieren können DXF-Punkte für Konstruktionszwecke aktiviert werden. Dabei werden DXF-Punkte nur im sichtbaren Zoomfenster aktiviert, alle Punkte außerhalb bleiben passiv. Durch Konstruktionspunkte deaktivieren kann die Aktion rückgängig gemacht werden.

Im Hintergrund liegt die DXF-Datei mit den geplanten Mischwasserkanälen (Magenta), diese wurden in diesem Fall nachdigitalisiert.

Kanabis 021.png